aboutsummaryrefslogtreecommitdiff
path: root/macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'macros/Cargo.toml')
-rw-r--r--macros/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/macros/Cargo.toml b/macros/Cargo.toml
new file mode 100644
index 0000000..74b4f91
--- /dev/null
+++ b/macros/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "syrette_macros"
+version = "0.1.0"
+license = "LGPL-2.1"
+authors = ["HampusM <hampus@hampusmat.com>"]
+description = "Macros for Syrette, the convenient dependency injection library"
+repository = "https://git.hampusmat.com/syrette"
+keywords = ["DI", "dependency-injection", "ioc", "inversion-of-control"]
+edition = "2021"
+
+[lib]
+proc_macro = true
+
+[dependencies]
+syn = { version = "1.0.96", features = ["full"] }
+quote = "1.0.18"
+proc-macro2 = "1.0.40"
+uuid = { version = "0.8", features = ["v4"] }
+