aboutsummaryrefslogtreecommitdiff
path: root/macros/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-07-20 14:29:45 +0200
committerHampusM <hampus@hampusmat.com>2022-07-20 14:29:45 +0200
commit2d1a6b2d432408d74eb57e0bda3f7434617e1070 (patch)
tree7e21f8126edfdfd9c40b4b51ba5626c6440442d9 /macros/Cargo.toml
parent7863d9859a5cbce99c3769e4fdb40283115d358d (diff)
refactor: reorganize folder hierarchy
Diffstat (limited to 'macros/Cargo.toml')
-rw-r--r--macros/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/macros/Cargo.toml b/macros/Cargo.toml
new file mode 100644
index 0000000..74b4f91
--- /dev/null
+++ b/macros/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "syrette_macros"
+version = "0.1.0"
+license = "LGPL-2.1"
+authors = ["HampusM <hampus@hampusmat.com>"]
+description = "Macros for Syrette, the convenient dependency injection library"
+repository = "https://git.hampusmat.com/syrette"
+keywords = ["DI", "dependency-injection", "ioc", "inversion-of-control"]
+edition = "2021"
+
+[lib]
+proc_macro = true
+
+[dependencies]
+syn = { version = "1.0.96", features = ["full"] }
+quote = "1.0.18"
+proc-macro2 = "1.0.40"
+uuid = { version = "0.8", features = ["v4"] }
+