aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 20 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a0e6dd9..41d00f8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,24 @@
+[package]
+name = "syrette"
+version = "0.1.0"
+license = "LGPL-2.1"
+authors = ["HampusM <hampus@hampusmat.com>"]
+description = "The convenient dependency injection library"
+repository = "https://git.hampusmat.com/syrette"
+keywords = ["DI", "dependency-injection", "ioc", "inversion-of-control"]
+edition = "2021"
+
+[dependencies]
+syrette_macros = "0.1.0"
+linkme = "0.3.0"
+once_cell = "1.4"
+error-stack = "0.1.1"
+
+[dev_dependencies]
+mockall = "0.11.1"
+
[workspace]
members = [
- "syrette",
- "syrette_macros",
+ "macros",
"example",
]