aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-07-20 14:29:45 +0200
committerHampusM <hampus@hampusmat.com>2022-07-20 14:29:45 +0200
commit2d1a6b2d432408d74eb57e0bda3f7434617e1070 (patch)
tree7e21f8126edfdfd9c40b4b51ba5626c6440442d9 /Cargo.toml
parent7863d9859a5cbce99c3769e4fdb40283115d358d (diff)
refactor: reorganize folder hierarchy
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 20 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a0e6dd9..41d00f8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,24 @@
+[package]
+name = "syrette"
+version = "0.1.0"
+license = "LGPL-2.1"
+authors = ["HampusM <hampus@hampusmat.com>"]
+description = "The convenient dependency injection library"
+repository = "https://git.hampusmat.com/syrette"
+keywords = ["DI", "dependency-injection", "ioc", "inversion-of-control"]
+edition = "2021"
+
+[dependencies]
+syrette_macros = "0.1.0"
+linkme = "0.3.0"
+once_cell = "1.4"
+error-stack = "0.1.1"
+
+[dev_dependencies]
+mockall = "0.11.1"
+
[workspace]
members = [
- "syrette",
- "syrette_macros",
+ "macros",
"example",
]