aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-08-03 11:50:59 +0200
committerHampusM <hampus@hampusmat.com>2022-08-03 11:50:59 +0200
commitc33cf02c9a6fffc6149fd7b59c63ad0d15d61432 (patch)
treef72edf77d7f10de85012fa869ecd01e8b161c435 /Cargo.toml
parent3db388dd567fbabb6a88ee7100de65442089c3f1 (diff)
refactor: add Cargo feature for preventing circular dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ac1cee9..3fd751a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,9 @@ edition = "2021"
all-features = true
[features]
+default = ["prevent-circular"]
factory = ["syrette_macros/factory"]
+prevent-circular = ["syrette_macros/prevent-circular"]
[[example]]
name = "factory"