summaryrefslogtreecommitdiff
path: root/engine/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2024-11-24 21:04:30 +0100
committerHampusM <hampus@hampusmat.com>2024-11-24 21:04:30 +0100
commit09b9f3c1cbd93c75b2fe69257b278ad3f993adf4 (patch)
tree8de3ad13c46ec6856e81dc75c047facc11c747c2 /engine/Cargo.toml
parentb233ff766a2e399a0a48a98e1f2121e960254950 (diff)
refactor(engine): remove 'debug' crate feature flag
Diffstat (limited to 'engine/Cargo.toml')
-rw-r--r--engine/Cargo.toml5
1 files changed, 1 insertions, 4 deletions
diff --git a/engine/Cargo.toml b/engine/Cargo.toml
index b3868ac..a2cc7aa 100644
--- a/engine/Cargo.toml
+++ b/engine/Cargo.toml
@@ -3,15 +3,12 @@ name = "engine"
version = "0.1.0"
edition = "2021"
-[features]
-debug = ["dep:tracing"]
-
[dependencies]
glfw = { path = "../glfw", features = ["opengl"] }
thiserror = "1.0.49"
gl = "0.14.0"
bitflags = "2.4.0"
-tracing = { version = "0.1.39", optional = true }
+tracing = "0.1.39"
seq-macro = "0.3.5"
paste = "1.0.14"
ecs = { path = "../ecs" }