summaryrefslogtreecommitdiff
path: root/ecs/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2024-12-20 21:27:48 +0100
committerHampusM <hampus@hampusmat.com>2024-12-20 21:27:56 +0100
commitbe7d20f0c57cc834e943426090fe2debf76ca98d (patch)
tree8b81d1dd06bc7d486120f993e3e3e70e48cb34c6 /ecs/Cargo.toml
parentcd30a25d2a75cadfe990ae6c1ae2eca5d927a8a7 (diff)
perf(ecs): use hashbrown's HashMap & HashSet
Hashbrown's HashMap & HashSet is faster than std's. I guess this is because std (which uses hashbrown) does not enable hashbrown's default-hasher flag and instead uses a slower hasher.
Diffstat (limited to 'ecs/Cargo.toml')
-rw-r--r--ecs/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/ecs/Cargo.toml b/ecs/Cargo.toml
index 3bf3b19..68d74f9 100644
--- a/ecs/Cargo.toml
+++ b/ecs/Cargo.toml
@@ -12,6 +12,7 @@ paste = "1.0.14"
thiserror = "1.0.49"
tracing = { version = "0.1.39", optional = true }
linkme = "0.3.29"
+hashbrown = "0.15.2"
ecs-macros = { path = "../ecs-macros" }
util-macros = { path = "../util-macros" }