summaryrefslogtreecommitdiff
path: root/ecs/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2024-03-29 14:20:21 +0100
committerHampusM <hampus@hampusmat.com>2024-03-29 14:20:21 +0100
commit61dfcf1ba2049bf0375821652e49b0e4c4147623 (patch)
tree3eaa2624523c893cb12b08595c4dd9e5250728c4 /ecs/Cargo.toml
parent96ba84e42c77147d297b358c944a48fee3785ae1 (diff)
feat(ecs): make World unwind safe
Diffstat (limited to 'ecs/Cargo.toml')
-rw-r--r--ecs/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/ecs/Cargo.toml b/ecs/Cargo.toml
index 44f1b24..ad0f373 100644
--- a/ecs/Cargo.toml
+++ b/ecs/Cargo.toml
@@ -3,9 +3,14 @@ name = "ecs"
version = "0.1.0"
edition = "2021"
+[features]
+debug = ["dep:tracing"]
+
[dependencies]
seq-macro = "0.3.5"
paste = "1.0.14"
+thiserror = "1.0.49"
+tracing = { version = "0.1.39", optional = true }
ecs-macros = { path = "../ecs-macros" }
util-macros = { path = "../util-macros" }