aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
new file mode 100644
index 0000000..16c32fd
--- /dev/null
+++ b/lib/CMakeLists.txt
@@ -0,0 +1,9 @@
+include(FetchContent)
+
+FetchContent_Declare(
+ ctre
+ GIT_REPOSITORY "https://github.com/hanickadot/compile-time-regular-expressions"
+ GIT_TAG v3.5
+)
+
+add_subdirectory(ctre)