aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-02-25 18:13:54 +0100
committerHampusM <hampus@hampusmat.com>2022-06-13 17:56:53 +0200
commitd36ec4670770022c0ec8337f6df4de292ca941db (patch)
treee4ae33c1470ef3fc63486b5d82b0a5d7377e747f /lib/CMakeLists.txt
parentc41090d12f4c7269524124dc0a2b5f9a03a61d93 (diff)
build: add ctre library dependency
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
new file mode 100644
index 0000000..16c32fd
--- /dev/null
+++ b/lib/CMakeLists.txt
@@ -0,0 +1,9 @@
+include(FetchContent)
+
+FetchContent_Declare(
+ ctre
+ GIT_REPOSITORY "https://github.com/hanickadot/compile-time-regular-expressions"
+ GIT_TAG v3.5
+)
+
+add_subdirectory(ctre)