aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-06-13 23:41:31 +0200
committerHampusM <hampus@hampusmat.com>2022-06-13 23:41:31 +0200
commit65c9a400d56b7412dbac03d93412ba4de1734396 (patch)
treebddc51e4234a5b087b2d026856eac15f3d0678e5 /lib/CMakeLists.txt
parent26e628b2721867b082fc26466017225c6105cde7 (diff)
refactor: add uncaught exception stack traces
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 9a18dbe..b42daad 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -32,6 +32,15 @@ FetchContent_Declare(
add_subdirectory(ctre)
+FetchContent_Declare(
+ backward
+ GIT_REPOSITORY "https://github.com/bombela/backward-cpp"
+ GIT_TAG v1.6
+)
+
+add_subdirectory(backward)
+
+
if(test)
FetchContent_Declare(
gtest