aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-04-30 16:28:13 +0200
committerHampusM <hampus@hampusmat.com>2022-06-13 17:56:58 +0200
commit40d02748924aa7c48b04cf948204d8dacdfbbc74 (patch)
tree4d07a3703207295799b02cef52618a8f0c820542 /lib/CMakeLists.txt
parentdb6edcd473a684420e9a7611b24462df21165c1b (diff)
refactor: replace DI files with the yacppdic library
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 0873b00..7fdf83c 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -24,6 +24,14 @@ FetchContent_Declare(
add_subdirectory(GSL)
+FetchContent_Declare(
+ yacppdic
+ GIT_REPOSITORY "https://git.hampusmat.com/yacppdic"
+ GIT_TAG v0.1.2
+)
+
+add_subdirectory(yacppdic)
+
if("${TESTING}")
FetchContent_Declare(
doctest