aboutsummaryrefslogtreecommitdiff
path: root/syrette_macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'syrette_macros/Cargo.toml')
-rw-r--r--syrette_macros/Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/syrette_macros/Cargo.toml b/syrette_macros/Cargo.toml
index 0d72785..a6966f0 100644
--- a/syrette_macros/Cargo.toml
+++ b/syrette_macros/Cargo.toml
@@ -6,4 +6,12 @@ authors = ["HampusM <hampus@hampusmat.com>"]
description = "Macros for Syrette, the convenient dependency injection library"
edition = "2021"
+[lib]
+proc_macro = true
+
[dependencies]
+syn = { version = "1.0.96", features = ["full"] }
+quote = "1.0.18"
+proc-macro2 = "1.0.40"
+uuid = { version = "0.8", features = ["v4"] }
+