aboutsummaryrefslogtreecommitdiff
path: root/macros/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2023-08-01 16:40:56 +0200
committerHampusM <hampus@hampusmat.com>2023-08-01 16:40:56 +0200
commitffad680e061dff1ac2fe30c2cbbb2d1d6e2f3461 (patch)
tree07c3d91606b4a215898915dc99f6e3de1eb12d32 /macros/Cargo.toml
parent3b5eae15afcd29a1775bb8ea046d6f42d996f67c (diff)
build: add temporary fix for predicates-tree MSRV change
The MSRV of predicates-tree (a dependency of mockall) was changed to 1.64.0 and released as a patch release, making this project not buildable using Rust 1.63.0. This commit fixes that by making sure only the latest version of predicates-tree with a 1.63.0 MSRV is used
Diffstat (limited to 'macros/Cargo.toml')
-rw-r--r--macros/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/macros/Cargo.toml b/macros/Cargo.toml
index 679e6b4..7349bed 100644
--- a/macros/Cargo.toml
+++ b/macros/Cargo.toml
@@ -36,3 +36,13 @@ mockall = "0.11.4"
pretty_assertions = "1.3.0"
syn = { version = "1.0.96", features = ["full", "extra-traits"] }
utility-macros = { git = "https://git.hampusmat.com/utility-macros" }
+
+# The following is needed because of this change:
+# https://github.com/assert-rs/predicates-rs/commit/7a961436d8c2b9cf09e9576a0c9341acb302f49c
+#
+# The predicates family of crates is a dependency of mockall.
+#
+# Follow this on
+# https://github.com/asomers/mockall/issues/507
+predicates-tree = "=1.0.7"
+predicates-core = "=1.0.5"