aboutsummaryrefslogtreecommitdiff
path: root/macros/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2024-09-12 19:35:13 +0200
committerHampusM <hampus@hampusmat.com>2024-09-12 19:35:13 +0200
commitb655d0e439da0da468e02d394e1189c5603fe752 (patch)
treefa564cca05e992d4cc6d856f95f67386bbcb160c /macros/Cargo.toml
parentca86952c1486b7f2313fef62e6cacf36e248efd2 (diff)
build: prevent warnings about unexpected cfgs
Diffstat (limited to 'macros/Cargo.toml')
-rw-r--r--macros/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/macros/Cargo.toml b/macros/Cargo.toml
index 890c9f3..adf4eda 100644
--- a/macros/Cargo.toml
+++ b/macros/Cargo.toml
@@ -41,3 +41,7 @@ pretty_assertions = "1.3.0"
syn = { version = "1.0.96", features = ["full", "extra-traits"] }
utility-macros = { git = "https://git.hampusmat.com/utility-macros" }
+[lints.rust.unexpected_cfgs]
+level = "warn"
+check-cfg = ["cfg(doc_cfg)", "cfg(tarpaulin_include)", "cfg(syrette_macros_logging)"]
+