aboutsummaryrefslogtreecommitdiff
path: root/macros/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2023-08-13 11:26:37 +0200
committerHampusM <hampus@hampusmat.com>2023-08-13 11:26:37 +0200
commit8f990a4477aa126e6bc79b98ba5f6685b0658fe7 (patch)
tree9ea852d71f3afa201f5633eb789ff488c6df1358 /macros/Cargo.toml
parent89c238f9c82ade2d7656e2bee76838a391609a88 (diff)
feat: add internal logging for macros
Diffstat (limited to 'macros/Cargo.toml')
-rw-r--r--macros/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/macros/Cargo.toml b/macros/Cargo.toml
index ccf10cd..4764221 100644
--- a/macros/Cargo.toml
+++ b/macros/Cargo.toml
@@ -30,6 +30,10 @@ once_cell = "1.13.1"
thiserror = "1.0.37"
proc-macro-error = "1.0.4"
+[target.'cfg(syrette_macros_logging)'.dependencies]
+tracing = "0.1.37"
+tracing-subscriber = "0.3.17"
+
[dev_dependencies]
syrette = { version = "0.4.2", path = ".." }
mockall = "0.11.4"