aboutsummaryrefslogtreecommitdiff
path: root/macros/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-10-15 18:40:20 +0200
committerHampusM <hampus@hampusmat.com>2022-10-15 18:40:20 +0200
commit740ef47d49e02ae2f2184f4c347d8eba8aee38fd (patch)
tree4a9cbf8f067b6e99f1f95dab774216d804829051 /macros/Cargo.toml
parentfdbd28fc18a5d2019132413b6699ff7691968fc2 (diff)
refactor: improve internals of macros & add unit tests
Diffstat (limited to 'macros/Cargo.toml')
-rw-r--r--macros/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/macros/Cargo.toml b/macros/Cargo.toml
index ff55afe..d71971e 100644
--- a/macros/Cargo.toml
+++ b/macros/Cargo.toml
@@ -26,6 +26,9 @@ proc-macro2 = "1.0.40"
uuid = { version = "0.8", features = ["v4"] }
regex = "1.6.0"
once_cell = "1.13.1"
+thiserror = "1.0.37"
[dev_dependencies]
syrette = { version = "0.4.0", path = "..", features = ["factory"] }
+mockall = "0.11.1"
+pretty_assertions = "1.3.0"