aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-08-20 17:10:08 +0200
committerHampusM <hampus@hampusmat.com>2022-08-21 18:17:50 +0200
commitade21185976ea2324d313a5c28a88cc0492f2934 (patch)
treef217d55ad324160d8a9a099c562c8bc6cbb60c1f /Cargo.toml
parentb31422d48a600ccccb682567f5eb11fc0bca547c (diff)
docs: add a example that uses a 3rd party library
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3fd751a..d49ab8c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,6 +20,10 @@ prevent-circular = ["syrette_macros/prevent-circular"]
name = "factory"
required-features = ["factory"]
+[[example]]
+name = "with-3rd-party"
+required-features = ["factory"]
+
[dependencies]
syrette_macros = { path = "./macros", version = "0.2.1" }
linkme = "0.3.0"
@@ -29,9 +33,11 @@ ahash = "0.7.6"
[dev_dependencies]
mockall = "0.11.1"
+third-party-lib = { path = "./examples/with-3rd-party/third-party-lib" }
[workspace]
members = [
"macros",
+ "examples/with-3rd-party/third-party-lib"
]