summaryrefslogtreecommitdiff
path: root/macros/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2023-03-18 17:14:42 +0100
committerHampusM <hampus@hampusmat.com>2023-03-18 17:15:30 +0100
commitc48271aef7e6b0819c497f302127c161845a83d7 (patch)
treea18d7b5fc8e017b4b7e0917a55534b28a01fe57d /macros/Cargo.toml
parent2ca8017deebe7bfe5aac368aead777a2c4910ca2 (diff)
refactor: rewrite the mock macro as a procedural macro
Diffstat (limited to 'macros/Cargo.toml')
-rw-r--r--macros/Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/macros/Cargo.toml b/macros/Cargo.toml
new file mode 100644
index 0000000..00efccf
--- /dev/null
+++ b/macros/Cargo.toml
@@ -0,0 +1,13 @@
+[package]
+name = "ridicule-macros"
+version = "0.1.0"
+edition = "2021"
+
+[lib]
+proc-macro = true
+
+[dependencies]
+quote = "1.0.26"
+syn = { version = "1.0.109", features = ["full", "printing"] }
+proc-macro-error = "1.0.4"
+proc-macro2 = "1.0.52"