aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2023-05-14 19:51:17 +0200
committerHampusM <hampus@hampusmat.com>2023-05-14 19:51:17 +0200
commitad142e9e749adf64642168c0d221b0cf47f149c7 (patch)
tree642308f9aec6032115c62bb6ae269fa37c3fc453 /Cargo.toml
parent4d46e44801d8ef40c8a2f4dea1d2c9088f2557a1 (diff)
refactor: use xml-stinksHEADmaster
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3af2b0f..d2ea91f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,13 +24,14 @@ all-features = true
rustdoc-args = ["--cfg", "doc_cfg"]
[dependencies]
-quick-xml = { version = "0.27.1" }
thiserror = "1.0.38"
+xml-stinks = { version = "0.1.0" }
[dev-dependencies]
pretty_assertions = "1.3.0"
criterion = "0.4.0"
-ridicule = "0.3.0"
+mockall = "0.11.4"
+xml-stinks = { version = "0.1.0", features = ["deserializer-static-generics"] }
[[bench]]
name = "registry"