aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-02-16 20:03:13 +0100
committerHampusM <hampus@hampusmat.com>2022-02-16 20:03:13 +0100
commitd5612756b98afa43443a210722691c2e07ddfd5c (patch)
treee8d718654996309b41fe1b00f6a6f13fba93ee0a /CMakeLists.txt
parent3908dd75438de89ebec2b0737634faf23ce93884 (diff)
refactor: add compiler warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b23ae1..e7b43c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,8 +21,15 @@ target_compile_options(
${PROJECT_NAME}
PRIVATE
-Wall -Wextra -Wpedantic -Wshadow
- -Wold-style-cast -Wcast-align -Wunused
- -Wconversion -pedantic -fsanitize=address
+ -Wold-style-cast -Wcast-align -Wno-unused
+ -Wconversion -Wcast-qual -Wctor-dtor-privacy
+ -Wdisabled-optimization -Wformat=2 -Winit-self
+ -Wlogical-op -Wmissing-declarations
+ -Wmissing-include-dirs -Wnoexcept -Woverloaded-virtual
+ -Wredundant-decls -Wsign-conversion -Wsign-promo
+ -Wstrict-null-sentinel -Wstrict-overflow=5 -Wswitch-default
+ -Wundef -Werror
+ -pedantic -fsanitize=address
)
target_include_directories(${PROJECT_NAME} PRIVATE src)