summaryrefslogtreecommitdiff
path: root/ecs/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ecs/Cargo.toml')
-rw-r--r--ecs/Cargo.toml15
1 files changed, 11 insertions, 4 deletions
diff --git a/ecs/Cargo.toml b/ecs/Cargo.toml
index 342f087..4945171 100644
--- a/ecs/Cargo.toml
+++ b/ecs/Cargo.toml
@@ -3,15 +3,22 @@ name = "ecs"
version = "0.1.0"
edition = "2021"
-[features]
-debug = ["dep:tracing"]
-
[dependencies]
seq-macro = "0.3.5"
paste = "1.0.14"
thiserror = "1.0.49"
-tracing = { version = "0.1.39", optional = true }
+tracing = "0.1.39"
linkme = "0.3.29"
+hashbrown = "0.15.2"
+parking_lot = "0.12.3"
ecs-macros = { path = "../ecs-macros" }
util-macros = { path = "../util-macros" }
+[dev-dependencies.criterion]
+version = "0.5.1"
+default-features = false
+features = ["cargo_bench_support"]
+
+[[bench]]
+name = "query"
+harness = false