summaryrefslogtreecommitdiff
path: root/engine/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2023-10-15 00:06:07 +0200
committerHampusM <hampus@hampusmat.com>2023-10-15 00:06:07 +0200
commitda329909f93597970afd169cee28ece3bee7127b (patch)
treeb8ce428d458ab5e3e699334877253b10a62c8fe2 /engine/Cargo.toml
parent46f27f31e425f5eba494f499bd7a6ac8f8713c2a (diff)
feat(engine): add logging OpenGL debug messages
Diffstat (limited to 'engine/Cargo.toml')
-rw-r--r--engine/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/engine/Cargo.toml b/engine/Cargo.toml
index 40b2e9f..ff52cce 100644
--- a/engine/Cargo.toml
+++ b/engine/Cargo.toml
@@ -3,8 +3,12 @@ name = "engine"
version = "0.1.0"
edition = "2021"
+[features]
+debug = ["dep:tracing"]
+
[dependencies]
glfw = { path = "../glfw" }
thiserror = "1.0.49"
gl = "0.14.0"
bitflags = "2.4.0"
+tracing = { version = "0.1.39", optional = true }