summaryrefslogtreecommitdiff
path: root/ecs/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2025-03-23 20:01:28 +0100
committerHampusM <hampus@hampusmat.com>2025-03-23 20:01:56 +0100
commitfd3e5efa4609b1eabd3d982099293e04a80a1ee7 (patch)
tree780ae2b19a0bc6e2df4c03b923a9d0e8e424a42d /ecs/Cargo.toml
parent98c9c63f2471fb6662e8c542762d4f6caf4fb7cd (diff)
feat(ecs): add integration with vizoxide crate
Diffstat (limited to 'ecs/Cargo.toml')
-rw-r--r--ecs/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/ecs/Cargo.toml b/ecs/Cargo.toml
index 4945171..cf35a74 100644
--- a/ecs/Cargo.toml
+++ b/ecs/Cargo.toml
@@ -3,6 +3,9 @@ name = "ecs"
version = "0.1.0"
edition = "2021"
+[features]
+vizoxide = ["dep:vizoxide"]
+
[dependencies]
seq-macro = "0.3.5"
paste = "1.0.14"
@@ -13,6 +16,7 @@ hashbrown = "0.15.2"
parking_lot = "0.12.3"
ecs-macros = { path = "../ecs-macros" }
util-macros = { path = "../util-macros" }
+vizoxide = { version = "1.0.5", optional = true }
[dev-dependencies.criterion]
version = "0.5.1"