summaryrefslogtreecommitdiff
path: root/ecs-macros/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2024-02-26 20:05:27 +0100
committerHampusM <hampus@hampusmat.com>2024-02-26 20:16:27 +0100
commit815d04da602c58ed8b13eeb612fe73180204039d (patch)
treec3703e598656c070edbc271ccaa9117e071d6d4f /ecs-macros/Cargo.toml
parent1019924a29527eba2c8ec8bd976ece6ed76075b0 (diff)
fix(ecs): make Component trait not automatic & add derive macro
Diffstat (limited to 'ecs-macros/Cargo.toml')
-rw-r--r--ecs-macros/Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/ecs-macros/Cargo.toml b/ecs-macros/Cargo.toml
new file mode 100644
index 0000000..792ca34
--- /dev/null
+++ b/ecs-macros/Cargo.toml
@@ -0,0 +1,13 @@
+[package]
+name = "ecs-macros"
+version = "0.1.0"
+edition = "2021"
+
+[lib]
+proc-macro = true
+
+[dependencies]
+quote = "1.0.35"
+syn = { version = "2.0.51", features = ["full"] }
+proc-macro2 = "1.0.78"
+