aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a566c12..0c576e3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -30,6 +30,12 @@ file(GLOB SOURCES
add_executable(${PROJECT_NAME} ${SOURCES})
+set_target_properties(
+ ${PROJECT_NAME}
+ PROPERTIES
+ RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}
+)
+
target_compile_features(${PROJECT_NAME} PUBLIC cxx_std_20)
target_compile_options(
@@ -44,7 +50,7 @@ target_compile_options(
-Wsign-conversion -Wsign-promo
-Wstrict-overflow=5 -Wswitch-default
-Wundef -Werror
- -pedantic -fsanitize=address -fno-exceptions
+ -pedantic -fsanitize=address -fno-exceptions -fno-omit-frame-pointer
)
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")