aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 6a5d90d..4e2b318 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -43,10 +43,18 @@ add_subdirectory(backward)
if(test)
FetchContent_Declare(
- gtest
- GIT_REPOSITORY "https://github.com/google/googletest"
- GIT_TAG v1.11.0
+ catch2
+ GIT_REPOSITORY "https://github.com/catchorg/Catch2"
+ GIT_TAG v3.0.1
)
- add_subdirectory(gtest)
+ add_subdirectory(catch2)
+
+ FetchContent_Declare(
+ trompeloeil
+ GIT_REPOSITORY "https://github.com/rollbear/trompeloeil"
+ GIT_TAG v42
+ )
+
+ add_subdirectory(trompeloeil)
endif()