aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-06-12 13:44:58 +0200
committerHampusM <hampus@hampusmat.com>2022-06-13 17:57:01 +0200
commit927e065f9829045247be7c0b3296408b6f577c1f (patch)
tree7da3d9cd5aa4070414a8708a582f6c3ab3e1e708 /src/CMakeLists.txt
parenteb66598c326862fd9dfc1899be4eac93f81a8023 (diff)
feat: add reading RLE files
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 52c5679..f6b27cb 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -11,10 +11,12 @@ endfunction(target_link_libraries_system)
file(GLOB SOURCES
bootstrap.cpp
util/color.cpp
+ util/fs.cpp
game/game.cpp
game/status_manager.cpp
game/generation_tracker.cpp
game/components/statusline.cpp
+ game/RLE_reader.cpp
engine/engine.cpp
engine/main.cpp
engine/data/vector2.cpp
@@ -47,7 +49,7 @@ target_compile_options(
-Wsign-conversion -Wsign-promo
-Wstrict-overflow=5 -Wswitch-default
-Wundef -Werror
- -pedantic -fsanitize=address -fno-exceptions -fno-omit-frame-pointer
+ -pedantic -fsanitize=address -fno-omit-frame-pointer
)
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
@@ -65,6 +67,7 @@ target_link_libraries_system(
fmt::fmt-header-only
GSL
yacppdic
+ ctre
)
target_link_options(${PROJECT_NAME} PRIVATE -fsanitize=address)