aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-06-02 19:51:54 +0200
committerHampusM <hampus@hampusmat.com>2022-06-13 17:57:00 +0200
commiteecf4b1e666211a13afa56f93477c55e8fd01621 (patch)
tree410510d6e058995174d5a5b0f535fb457a0c3542 /lib/CMakeLists.txt
parent87f55120f96d0f4f80b497dc9006d89df2dda125 (diff)
feat: implement game of lifev0.1.0
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 7fdf83c..df9b253 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -32,12 +32,12 @@ FetchContent_Declare(
add_subdirectory(yacppdic)
-if("${TESTING}")
+if(test)
FetchContent_Declare(
- doctest
- GIT_REPOSITORY "https://github.com/doctest/doctest"
- GIT_TAG v2.4.8
+ gtest
+ GIT_REPOSITORY "https://github.com/google/googletest"
+ GIT_TAG v1.11.0
)
- add_subdirectory(doctest)
+ add_subdirectory(gtest)
endif()