aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-06-12 13:44:58 +0200
committerHampusM <hampus@hampusmat.com>2022-06-13 17:57:01 +0200
commit927e065f9829045247be7c0b3296408b6f577c1f (patch)
tree7da3d9cd5aa4070414a8708a582f6c3ab3e1e708 /lib/CMakeLists.txt
parenteb66598c326862fd9dfc1899be4eac93f81a8023 (diff)
feat: add reading RLE files
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 84c5a77..9a18dbe 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -24,6 +24,14 @@ FetchContent_Declare(
add_subdirectory(yacppdic)
+FetchContent_Declare(
+ ctre
+ GIT_REPOSITORY "https://github.com/hanickadot/compile-time-regular-expressions"
+ GIT_TAG v3.7
+)
+
+add_subdirectory(ctre)
+
if(test)
FetchContent_Declare(
gtest