summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-10-02 15:53:05 +0200
committerHampusM <hampus@hampusmat.com>2022-10-02 15:53:56 +0200
commitbebd446c2cdb1645be7197fa738a66b73449bfc5 (patch)
treef108476e54ce64de512d1e3636216e6291e86204 /Cargo.toml
parent930769ed7eb2a2b8af849f6c30661823351ae277 (diff)
feat: add feature_specific macroHEADv0.1.0master
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..c8cf026
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "feature_macros"
+license = "MIT OR Apache-2.0"
+version = "0.1.0"
+description = "Utility macros for utilizing cargo features"
+edition = "2021"
+
+[lib]
+proc_macro = true
+
+[dependencies]
+syn = { version = "1.0.101", features = ["full"] }
+quote = "1.0.21"
+proc-macro2 = "1.0.46"