aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-04-26 20:16:22 +0200
committerHampusM <hampus@hampusmat.com>2022-04-26 20:19:23 +0200
commitd2a87d5803c7aaa9a47791a5a0f1494c19671ebc (patch)
tree5dcc645cafe5c1986b66b0af0c9a62663c261ecb /CMakeLists.txt
parentdbe0e42817964b700385ac6ed7b7dc2141669e17 (diff)
add project & make some tweaks
Added from https://git.hampusmat.com/game-of-life
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..9810762
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.2.0)
+
+project(yacppdic CXX)
+
+add_library(${PROJECT_NAME} INTERFACE)
+
+target_include_directories(
+ ${PROJECT_NAME}
+ INTERFACE
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
+)
+
+add_library(${PROJECT_NAME}::${PROJECT_NAME} ALIAS ${PROJECT_NAME})
+
+add_subdirectory(test)