aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a202540..d4a4312 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,6 +8,13 @@ repository = "https://git.hampusmat.com/syrette"
keywords = ["DI", "dependency-injection", "ioc", "inversion-of-control"]
edition = "2021"
+[features]
+factory = []
+
+[[example]]
+name = "factory"
+required-features = ["factory"]
+
[dependencies]
syrette_macros = { path = "./macros", version = "0.1.0" }
linkme = "0.3.0"