diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -17,7 +17,7 @@ rustdoc-args = ["--cfg", "doc_cfg"] default = ["prevent-circular"] factory = ["syrette_macros/factory"] prevent-circular = ["syrette_macros/prevent-circular"] -async = ["dep:async-trait", "dep:tokio"] +async = ["dep:async-trait", "dep:async-lock"] [[example]] name = "factory" @@ -49,7 +49,7 @@ strum = "0.24.1" strum_macros = "0.24.3" paste = "1.0.8" async-trait = { version = "0.1.57", optional = true } -tokio = { version = "1.20.1", features = ["sync"], optional = true } +async-lock = { version = "2.6.0", optional = true } [dev_dependencies] mockall = { git = "https://github.com/HampusMat/mockall" } |