diff options
author | HampusM <hampus@hampusmat.com> | 2022-11-17 21:01:47 +0100 |
---|---|---|
committer | HampusM <hampus@hampusmat.com> | 2022-11-17 21:01:47 +0100 |
commit | d99cbf9fa95856cbc14a3217e1cd3f13aeb2e0b3 (patch) | |
tree | fa3596d53a850fb4d8d12e853789446acea7c3e2 /Cargo.toml | |
parent | 6a8fb450b5ac3e365455abe783757b7376bd1b08 (diff) |
refactor: use the async-lock crate instead of Tokio
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -17,7 +17,7 @@ rustdoc-args = ["--cfg", "doc_cfg"] default = ["prevent-circular"] factory = ["syrette_macros/factory"] prevent-circular = ["syrette_macros/prevent-circular"] -async = ["dep:async-trait", "dep:tokio"] +async = ["dep:async-trait", "dep:async-lock"] [[example]] name = "factory" @@ -49,7 +49,7 @@ strum = "0.24.1" strum_macros = "0.24.3" paste = "1.0.8" async-trait = { version = "0.1.57", optional = true } -tokio = { version = "1.20.1", features = ["sync"], optional = true } +async-lock = { version = "2.6.0", optional = true } [dev_dependencies] mockall = { git = "https://github.com/HampusMat/mockall" } |