diff options
author | HampusM <hampus@hampusmat.com> | 2022-08-21 14:19:07 +0200 |
---|---|---|
committer | HampusM <hampus@hampusmat.com> | 2022-08-21 18:17:51 +0200 |
commit | 8c66b98bca6ed0a2990903fe8e0ea72def5c7be8 (patch) | |
tree | deed78171051262dba7e8d97eba73a9aaf04dd5e /Cargo.toml | |
parent | b3e1b993b028bbfa73638236cfbdb50ee478d3f0 (diff) |
refactor!: change errors to be more sane
BREAKING CHANGE: Major improvements have been made to error types and the error_stack crate is no longer used
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -28,8 +28,10 @@ required-features = ["factory"] syrette_macros = { path = "./macros", version = "0.2.1" } linkme = "0.3.0" once_cell = "1.4" -error-stack = "0.1.1" ahash = "0.7.6" +thiserror = "1.0.32" +strum = "0.24.1" +strum_macros = "0.24.3" [dev_dependencies] mockall = "0.11.1" |