diff options
author | HampusM <hampus@hampusmat.com> | 2022-10-23 18:12:23 +0200 |
---|---|---|
committer | HampusM <hampus@hampusmat.com> | 2022-10-23 18:12:23 +0200 |
commit | 9e01cdf341a7866180b3a63d745f3b2d7578d28a (patch) | |
tree | 0c036b7b4a68e44b6eb2221bf7beb3c34fe9c1c8 /Cargo.toml | |
parent | 740ef47d49e02ae2f2184f4c347d8eba8aee38fd (diff) |
refactor!: reduce DI container coupling
BREAKING CHANGE: You now have to import the DI containers's interfaces to use the DI containers's methods
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -47,7 +47,7 @@ async-trait = { version = "0.1.57", optional = true } tokio = { version = "1.20.1", features = ["sync"], optional = true } [dev_dependencies] -mockall = "0.11.1" +mockall = { git = "https://github.com/HampusMat/mockall" } anyhow = "1.0.62" third-party-lib = { path = "./examples/with-3rd-party/third-party-lib" } tokio = { version = "1.20.1", features = ["macros", "rt-multi-thread", "time"] } |