diff options
author | HampusM <hampus@hampusmat.com> | 2022-08-29 20:52:56 +0200 |
---|---|---|
committer | HampusM <hampus@hampusmat.com> | 2022-08-29 21:01:32 +0200 |
commit | 080cc42bb1da09059dbc35049a7ded0649961e0c (patch) | |
tree | 307ee564124373616022c1ba2b4d5af80845cd92 /Cargo.toml | |
parent | 6e31d8f9e46fece348f329763b39b9c6f2741c07 (diff) |
feat: implement async functionality
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -15,6 +15,7 @@ all-features = true default = ["prevent-circular"] factory = ["syrette_macros/factory"] prevent-circular = ["syrette_macros/prevent-circular"] +async = ["async-trait"] [[example]] name = "factory" @@ -24,6 +25,10 @@ required-features = ["factory"] name = "with-3rd-party" required-features = ["factory"] +[[example]] +name = "async" +required-features = ["async"] + [dependencies] syrette_macros = { path = "./macros", version = "0.3.0" } linkme = "0.3.0" @@ -33,11 +38,13 @@ thiserror = "1.0.32" strum = "0.24.1" strum_macros = "0.24.3" paste = "1.0.8" +async-trait = { version = "0.1.57", optional = true } [dev_dependencies] mockall = "0.11.1" anyhow = "1.0.62" third-party-lib = { path = "./examples/with-3rd-party/third-party-lib" } +tokio = { version = "1.20.1", features = ["full"] } [workspace] members = [ |