diff options
author | HampusM <hampus@hampusmat.com> | 2022-09-18 13:03:41 +0200 |
---|---|---|
committer | HampusM <hampus@hampusmat.com> | 2022-09-18 13:03:41 +0200 |
commit | e779f4cf030c6a960b0c78ed3771ba4de55a5d0f (patch) | |
tree | d1fe4ca47d50fd7869a03b606fee02e4b6dc5804 /Cargo.toml | |
parent | 8d0e981717aa15ce6cfd9b04e489be73623f1e92 (diff) |
build: improve async dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -15,7 +15,7 @@ all-features = true default = ["prevent-circular"] factory = ["syrette_macros/factory"] prevent-circular = ["syrette_macros/prevent-circular"] -async = ["async-trait"] +async = ["dep:async-trait", "dep:tokio"] [[example]] name = "factory" @@ -39,13 +39,13 @@ strum = "0.24.1" strum_macros = "0.24.3" paste = "1.0.8" async-trait = { version = "0.1.57", optional = true } -tokio = "1.20.1" +tokio = { version = "1.20.1", features = ["sync"], optional = true } [dev_dependencies] mockall = "0.11.1" anyhow = "1.0.62" third-party-lib = { path = "./examples/with-3rd-party/third-party-lib" } -tokio = { version = "1.20.1", features = ["full"] } +tokio = { version = "1.20.1", features = ["macros", "rt-multi-thread"] } [workspace] members = [ |