diff options
author | HampusM <hampus@hampusmat.com> | 2022-08-20 17:10:08 +0200 |
---|---|---|
committer | HampusM <hampus@hampusmat.com> | 2022-08-21 18:17:50 +0200 |
commit | ade21185976ea2324d313a5c28a88cc0492f2934 (patch) | |
tree | f217d55ad324160d8a9a099c562c8bc6cbb60c1f /Cargo.toml | |
parent | b31422d48a600ccccb682567f5eb11fc0bca547c (diff) |
docs: add a example that uses a 3rd party library
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -20,6 +20,10 @@ prevent-circular = ["syrette_macros/prevent-circular"] name = "factory" required-features = ["factory"] +[[example]] +name = "with-3rd-party" +required-features = ["factory"] + [dependencies] syrette_macros = { path = "./macros", version = "0.2.1" } linkme = "0.3.0" @@ -29,9 +33,11 @@ ahash = "0.7.6" [dev_dependencies] mockall = "0.11.1" +third-party-lib = { path = "./examples/with-3rd-party/third-party-lib" } [workspace] members = [ "macros", + "examples/with-3rd-party/third-party-lib" ] |