aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..4ec937f
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "opengl-registry-macros"
+version = "0.1.0"
+license = "MIT OR Apache-2.0"
+edition = "2021"
+
+[lib]
+proc-macro = true
+
+[dependencies]
+once_cell = "1.17.0"
+proc-macro2 = "1.0.51"
+convert_case = "0.6.0"
+opengl-registry = { git = "https://git.hampusmat.com/opengl-registry-rs" }
+regex = "1.7.1"
+
+[dev-dependencies]
+quote = "1.0.23"
+pretty_assertions = "1.3.0"
+