aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2023-02-19 17:16:54 +0100
committerHampusM <hampus@hampusmat.com>2023-02-19 18:24:57 +0100
commit6b6f25357e25a07d234ae683c1b58b1929b8483e (patch)
tree5ff873b64aa21c0961d32c6aee056aca32481e20 /Cargo.toml
parentb3fc15dc216794419c7d97d9f4d7f596c26e9182 (diff)
feat: add project & for_each_opengl_command macro
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..4ec937f
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "opengl-registry-macros"
+version = "0.1.0"
+license = "MIT OR Apache-2.0"
+edition = "2021"
+
+[lib]
+proc-macro = true
+
+[dependencies]
+once_cell = "1.17.0"
+proc-macro2 = "1.0.51"
+convert_case = "0.6.0"
+opengl-registry = { git = "https://git.hampusmat.com/opengl-registry-rs" }
+regex = "1.7.1"
+
+[dev-dependencies]
+quote = "1.0.23"
+pretty_assertions = "1.3.0"
+