aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a817aba..f74c218 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,4 +4,9 @@ set(CMAKE_C_STANDARD 11)
project(mazerator_project C)
-add_subdirectory(src)
+file(GLOB SOURCES src/*.c)
+
+add_executable(mazerator ${SOURCES})
+
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+