aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt14
1 files changed, 5 insertions, 9 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 0c74bf2..8a92723 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,7 +1,5 @@
project(tests CXX)
-enable_testing()
-
file(GLOB SOURCES
cell_helper_test.cpp
${CMAKE_SOURCE_DIR}/src/game/cell_helper.cpp
@@ -18,14 +16,14 @@ target_compile_options(
PRIVATE
-Wall -Wextra -Wpedantic -Wshadow
-Wold-style-cast -Wcast-align -Wno-unused
- -Wconversion -Wcast-qual -Wctor-dtor-privacy
+ -Wconversion -Wcast-qual
-Wdisabled-optimization -Wformat=2 -Winit-self
-Wmissing-declarations -Wmissing-include-dirs
-Woverloaded-virtual -Wredundant-decls
-Wsign-conversion -Wsign-promo
-Wstrict-overflow=5 -Wswitch-default
-Wundef -Werror
- -pedantic -fsanitize=address -fno-exceptions
+ -pedantic -fsanitize=address
)
target_include_directories(
@@ -38,12 +36,10 @@ target_link_options(${PROJECT_NAME} PRIVATE -fsanitize=address)
target_link_libraries(
${PROJECT_NAME}
+ PRIVATE
GSL
yacppdic
- gtest_main
- gmock
+ Catch2::Catch2WithMain
+ trompeloeil
)
-include(GoogleTest)
-
-gtest_discover_tests(${PROJECT_NAME})