aboutsummaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 7fdf83c..df9b253 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -32,12 +32,12 @@ FetchContent_Declare(
add_subdirectory(yacppdic)
-if("${TESTING}")
+if(test)
FetchContent_Declare(
- doctest
- GIT_REPOSITORY "https://github.com/doctest/doctest"
- GIT_TAG v2.4.8
+ gtest
+ GIT_REPOSITORY "https://github.com/google/googletest"
+ GIT_TAG v1.11.0
)
- add_subdirectory(doctest)
+ add_subdirectory(gtest)
endif()