aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-03-20 13:17:16 +0100
committerHampusM <hampus@hampusmat.com>2022-06-13 17:56:56 +0200
commit78f5d8cf644383adf20933ad64c160c07c2c54fb (patch)
tree2a348d90f8f150665c379bf2f3741731999dd679 /src/CMakeLists.txt
parentb6061eff99907495de282f611e8389e6468a1fb0 (diff)
refactor: improve input configuring structure
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3ad9b06..1a52ae8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,7 +13,6 @@ file(GLOB SOURCES
bootstrap.cpp
conversion.cpp
argument_parser.cpp
- input_actions.cpp
util/color.cpp
game/game.cpp
engine/engine.cpp
@@ -26,6 +25,9 @@ file(GLOB SOURCES
engine/user/cursor.cpp
randomization/generator.cpp
randomization/seed_generator.cpp
+ commands/insert_cell.cpp
+ commands/move_cursor.cpp
+ commands/quit.cpp
DI/object_type.cpp)
add_executable(${PROJECT_NAME} ${SOURCES})