aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-03-23 19:41:31 +0100
committerHampusM <hampus@hampusmat.com>2022-06-13 17:56:57 +0200
commit486ca3846b46dc229e5807968578809766ec1991 (patch)
tree65a4b7a746d6305666af06f8a1975c76244085a7 /src/CMakeLists.txt
parentb8e86ce397dc07320c02f6a5f592c7c6a4421c86 (diff)
feat: implement generations & multithreading
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c603b37..4aa4a40 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -15,7 +15,9 @@ file(GLOB SOURCES
argument_parser.cpp
util/color.cpp
game/game.cpp
- game/cursor_listener.cpp
+ game/status_updater.cpp
+ game/generation_tracker.cpp
+ game/statusline.cpp
engine/engine.cpp
engine/data/vector2.cpp
engine/data/bounds.cpp
@@ -29,6 +31,7 @@ file(GLOB SOURCES
commands/insert_cell.cpp
commands/move_cursor.cpp
commands/quit.cpp
+ commands/toggle_pause.cpp
DI/object_type.cpp)
add_executable(${PROJECT_NAME} ${SOURCES})