aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHampusM <hampus@hampusmat.com>2022-03-10 19:12:31 +0100
committerHampusM <hampus@hampusmat.com>2022-06-13 17:56:55 +0200
commit38f14606c78c119d452f302f17329455e29a9a6f (patch)
tree03f6dfd9d3576e87260f7cb3bc436ad076b629c5 /src/CMakeLists.txt
parent09848ad31af6a1c70d64fccee711e231afb5a77f (diff)
refactor: rename game initializer & move input config
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 304aba1..0ef0c8e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,12 +13,13 @@ file(GLOB SOURCES
bootstrap.cpp
conversion.cpp
argument_parser.cpp
+ input_actions.cpp
game/game.cpp
- game/input_configurator.cpp
- engine/game_initializer.cpp
+ engine/engine.cpp
engine/data/vector2.cpp
engine/data/bounds.cpp
engine/graphics/scene.cpp
+ engine/graphics/window.cpp
engine/graphics/string_matrix.cpp
engine/user/input.cpp
engine/user/cursor.cpp